5.22 Crashed: Modified a Structure and Crashed


Ian
 

I was modifying a structure - the Canal Bridge at the very bottom of the layout - and was doing the last step and Grouping it again. It was giving me a different name - the name of the boat in the middle of the structure which wasn't highlighted. So I gave in an entirely new name and clicked OK. Sudden instant crash. Wow!
Layout and Ini files attached. I accidentally started this by clicking on the Layout file so the Log file wasn't updated. Sorry.
--
-- Ian


Adam Richards
 

Can't get that issue to happen, but I do see an issue if a group contains another group (like your boat end). The inner group is not being added to the new group.  It looks like the inner structure segments are not being added to tempSegs, so that they are not added to the final group.  They are then deleted if you replace with Group, though... 

The name is simply inherited from the last use of the Group command, BTW. It doesn't relate to the current contents, it helps those who are adding a sequence of similar parts.  

Adam


Ian
 

Continuing Saga. I imported the image and I could see it behind the modules, I knew I needed to Scale but before I did that I saved the Settings file. Then it crashed.


On Thu, 25 Feb 2021 at 12:23, Ian via groups.io <ilox11=gmail.com@groups.io> wrote:
I was modifying a structure - the Canal Bridge at the very bottom of the layout - and was doing the last step and Grouping it again. It was giving me a different name - the name of the boat in the middle of the structure which wasn't highlighted. So I gave in an entirely new name and clicked OK. Sudden instant crash. Wow!
Layout and Ini files attached. I accidentally started this by clicking on the Layout file so the Log file wasn't updated. Sorry.
--
-- Ian



--
-- Ian


Ian
 

(Repost due to the wrong image sent)

I was getting quite frustrated by this point so I did a full reboot of the PC and when it came back started off again. Yeah, you guessed it. No more problems Grrrrr.

I even got to achieve what I was looking to do which was place an image of the ScaleScenes Canal Wharf behind my Double Module and see just how it might look. How did I scale it? I simply cheated. I drew a couple of tracks and then kept scaling it down until the tracks fitted the tracks in the image. Close enough for this level of work.

Sigh. I cannot even imagine what was causing all the Crashing. Something didn't like something else and it would spit the dummy.


Ian
 

So I just started up XTrkCAD off the Icon with the Logging enabled. I was just about to try to put an image behind the left-side module (if that can be done.
I did a SaveAs to a new file name and it Crashed out immediately.
It didn't save the file but the Crash files have been updated to that moment if that helps?


On Thu, 25 Feb 2021 at 13:08, Adam Richards <adamjmrichards@...> wrote:
Can't get that issue to happen, but I do see an issue if a group contains another group (like your boat end). The inner group is not being added to the new group.  It looks like the inner structure segments are not being added to tempSegs, so that they are not added to the final group.  They are then deleted if you replace with Group, though... 

The name is simply inherited from the last use of the Group command, BTW. It doesn't relate to the current contents, it helps those who are adding a sequence of similar parts.  

Adam



--
-- Ian


Ian
 

Started again, did a SaveAs and Again it simply crashed without saving the file under the new name. This is screwy!

Not sure what all that Command Mouse info is. All I did was start the file, Select SaveAs and Crash!


On Thu, 25 Feb 2021 at 13:32, Ian <ilox11@...> wrote:
So I just started up XTrkCAD off the Icon with the Logging enabled. I was just about to try to put an image behind the left-side module (if that can be done.
I did a SaveAs to a new file name and it Crashed out immediately.
It didn't save the file but the Crash files have been updated to that moment if that helps?

On Thu, 25 Feb 2021 at 13:08, Adam Richards <adamjmrichards@...> wrote:
Can't get that issue to happen, but I do see an issue if a group contains another group (like your boat end). The inner group is not being added to the new group.  It looks like the inner structure segments are not being added to tempSegs, so that they are not added to the final group.  They are then deleted if you replace with Group, though... 

The name is simply inherited from the last use of the Group command, BTW. It doesn't relate to the current contents, it helps those who are adding a sequence of similar parts.  

Adam



--
-- Ian



--
-- Ian