Topics

Beta wont let me do anything to New Tracks - Calls it a Module?? #v5dot2 #module


Ian
 

Adam/Martin/ Crew, LOVE the Beta! Enjoyed building Bridges with one click. So cool. Enjoyed bringing in images of past tracks. Then the fun stopped.

I started a new layout and I found I can bring in the photo of a past track. So cool.

Then I brought in a T-TRAK XTI as a module, so easy. Then I was in trouble. I could add another line BUT it won't let me do anything else to it! Soon as I touch that line to Extend the track or connect a curve or something else, the system throws up a message that a module cant be changed. Hmm.

So I bring it in as an Import XTI, same thing. I select the Import and break it up into components with Ungroup. "You cannot change a module"

So then I start off fresh with just the Image behind the layout. I add a line to sit over the top of the image. So far so good. I touch the end to extend a curve. Up comes the message, You Can't change a module???

But all I have on the layout is the photo and one piece of track? Why is it talking about a module when nothing else has been imported? Does it think the photo is a module to be protected?

So being perverse I went to a New layout without a photo. Laid in some lines, great. Went to Modify a Line. Beep."Tracks in a Module cannot be modified."

I have uploaded the error file to my folder:  https://xtrackcad.groups.io/g/main/files/T-TRAK_modules_by_Ian/2020-0607-1200%20Error%20-%20Tracks%20in%20a%20module%20cannot%20be%20modified.xtc

Any advice, please.


Ian
 

And just to make it interesting, This layout has been started in 5.1.2a and then Imported over the background photo in Beta 5.2. All seemed to work fine.

(To turn off the background, the icon appears in the Task Bar as the first of the layers. )

None of the previous problems with error messages were noted other than at one time a small box popped up saying to "Check Pointers."

 
https://xtrackcad.groups.io/g/main/files/T-TRAK_modules_by_Ian//Test%20Triple%20with%20photo%20background.xtc


Adam Richards
 

Ian,
A module is a layer whose contents are fixed. This is a property of each layer and can be turned on/off (Manage->Layers). It differs from "frozen" in that the layer elements can be moved about and rotated (but only as a set). You can join track to it, but you can't modify within it.  Obviously if you turn module off for the layer all the elements work as usual.  

It differs from a group because it can contain many individual turnouts that can be operated individually in Train mode - whereas a group is treated like a single turnout with only one set of Paths.

When you import a track file you can choose to import as a module or not. If you do, a new layer with module turned on is used as the place to put it.

The purpose of modules is to support assembly of modular layouts. Each module is built separately and then they can be assembled together, snapping together as lego. Clubs who have modular layouts can see how they look assembled in different configurations and can simulate operations. 

I assume that the track you have is in a layer with module turned on - and we may have a bug because the current layer should never have module turned on, I think. Go to Manage->layers and see if it is on, and if you can turn it off.

Adam


Adam Richards
 
Edited

Also try "Import" rather than "Import Module" on the import....